Home Questions Sudden error in Dex.py

Sudden error in Dex.py

DWQA QuestionsCategory: Dexterit-ESudden error in Dex.py
barthelemy asked 4 years ago
Hi, I'm using Dexterit-E version 3.5.0 with a NHP kinarm system. Until yesterday, everything was fine but today Dexterit-E didn't run. Instead, a pop message reporting errors appeared. I tried to reinstall a fresh version of dexterit-E 3.5.4 but I've got the very same reslt with the same message in the Dex.exe.log   Traceback (most recent call last):
File "Dex.py", line 30, in <module>
File "zipextimporter.pyo", line 82, in load_module
File "utils\FeatureManager.pyo", line 4, in <module>
File "zipextimporter.pyo", line 82, in load_module
File "ConfigCache.pyo", line 531, in <module>
File "ConfigCache.pyo", line 450, in read
File "SortedSafeConfigParser.pyo", line 66, in read
File "ConfigParser.pyo", line 297, in read
File "ConfigParser.pyo", line 504, in _read
ConfigParser.MissingSectionHeaderError: File contains no section headers.
file: C:\Users\manip\AppData\Local\BKIN Technologies\Dexterit-E 3.5\DexUser.ini, line: 1
'\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00'   Do you have any idea of what could have happen ?   Sincerely Fred
Koloman Varady Staff replied 4 years ago

Hi Fred,

It looks like the settings file, DexUser.ini is corrupt. With an older version of Dexterit-E (such as v3.5), this could have happened while shutting down the computer before Dexterit-E is shutdown but can’t say for sure how it happened.

Can you go navigate in Windows File Explorer to C:\ProgramData\BKIN Technologies\Dexterit-E 3.5 and grab the files Dex.ini, Dex.ini.old, and Dex.log.

Then navigate to C:\Users\manip\AppData\Local\BKIN Technologies\Dexterit-E 3.5\ and grab DexUser.ini and DexUser.ini.old.

Then send those 5 files to support@kinarm.com

We’ll have a look at what happened and get you up and running again.


barthelemy replied 4 years ago

Thanks for this very fast answer. I’ll send the files in a minute. Cheers

1 Answers
barthelemy answered 4 years ago
Hi, After an email exchange with Duncan at support, the problem was solved by taking the DexUser.ini and the DexUser.ini.old and changing their location. New (and correct) versions of these files were generated after Dexterit-E started. Thanks Fred